Willkommen bei
Wealth Management Online

Browser requirements

The e-Banking requires to have at least one of the following internet browser with minimum version installed.
Microsoft Edge EdgeHTML: Version 18
Firefox: Version 70
Chrome: Version 78
Safari: Version 13